【易语言】如何调用接口

admin 2023-11-28 406 11/28

前言:我们在写软件的时候,经常需要调用一些网址,或者说需要解析一些json,来获取其中的数据,那么这里会大致讲解一下基本的网页访问,以及基本的json解析。

准备工作:

 

这里使用的是天行的ONEapi接口

先看api的官方例子与说明

 

 

【易语言】如何调用接口

开始操作

    • 打开精易编程助手进行测试

发现可以正常返回既可

【易语言】如何调用接口

 

 

      • 打开精易编程助手进行测试
使用json解析查看数组
    【易语言】如何调用接口

     

    开始编写代码

    创建窗口并添加一个编辑框

    【易语言】如何调用接口

    导入精易模块后双击窗口进行启动项编写

    基本代码如下:

    .版本 2
    
    .子程序 _启动窗口创建完毕
    .局部变量 one_网址, 文本型
    .局部变量 one_提交方式, 整数型
    .局部变量 one_协议头, 类POST数据类 .局部变量 one提交协议头, 文本型
    .局部变量 one_结果, 字节集
    .局部变量 one_返回, 文本型
    
    one_网址 = “https://apis.tianapi.com/one/index?key=您的key”
    one_提交方式 = 0
    one_协议头.添加 (“User-Agent”, “ Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0”)
    one_提交协议头 = one_协议头.获取协议头数据 ()
    one_结果 = 网页访问对象 (one_网址, one_提交方式, , , , one_提交协议头, , , , , )
    one_返回 = 编码utf8到gb2312 (到文本 (one结果))
    one_bq.内容 = one_返回
    

    查看编辑框的效果

    【易语言】如何调用接口

    接下来json解析来只获取文字内容

    添加如下代码

    .版本 2
    
    one_json.解析 (one_返回)
    one_文本 = one_json.取通用属性 (“result.word”)
    one_bq.内容 = one_文本
    
    【易语言】如何调用接口

    查看运行效果并稍微修改编辑框样式就可以了

    【易语言】如何调用接口
    .版本 2
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    .局部变量 one_网址, 文本型
    .局部变量 one_提交方式, 整数型
    .局部变量 one_协议头, 类_POST数据类
    .局部变量 one_提交协议头, 文本型
    .局部变量 one_结果, 字节集
    .局部变量 one_返回, 文本型
    .局部变量 one_json, 类_json
    .局部变量 one_文本, 文本型
    
    
    
    one_网址 = “https://apis.tianapi.com/one/index?key=您的key”
    one_提交方式 = 0
    one_协议头.添加 (“User-Agent”, “ Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0”)
    one_提交协议头 = one_协议头.获取协议头数据 ()
    one_结果 = 网页_访问_对象 (one_网址, one_提交方式, , , , one_提交协议头, , , , , )
    one_返回 = 编码_utf8到gb2312 (到文本 (one_结果))
    
    
    one_json.解析 (one_返回)
    one_文本 = one_json.取通用属性 (“result.word”)
    one_bq.内容 = one_文本
    

     

      - THE END -
      Tag:

      admin

      12月05日11:28

      最后修改:2023年12月5日
      1

      非特殊说明,本博所有文章均为博主原创。

      共有 0 条评论